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The information in this manual is subject to change withoutnotice.

Throughout this manual, the following notes are usedto alert you to safety
considerations:

 

 

ATTENTION: Identifies information about practices or

circumstancesthat can lead to personalinjury or death,
property damage, or economicloss.

 

Important: Identifies information thatis critical for successful application

and understanding of the product.

 

 

ATTENTION:Only qualified electrical personnel familiar with

the construction and operation of this equipment and the
hazardsinvolved should install, adjust, operate, and/or service

this equipment. Read and understand this manualin its

entirety before proceeding. Failure to observe these

precautions could result bodily injury and/or damageto
equipment.

ATTENTION: If the Serial Converteris transmitting control I/O
to the product (indicated by a steady green diamond LED on

the Serial Converter), the product may fault when you remove
or reset the Serial Converter. Determine how your productwill
respond before removing or resetting a connected Serial

Converter. Failure to observe this precaution could result

bodily injury and/or damage to equipment.

ATTENTION: Thesetting of Comm Fit Action (04) determines

the action of the Serial Converter and connected productif
DF1 serial communications are disrupted. By default, this

parameterfaults the product. You can set this parameter so

that the product continues to run. Ensure that the setting of
this parameter does not create a hazard. Failure to observe

this precaution could result bodily injury and/or damage to
equipment.
 

Reliance, MD60, and VS Utilities are trademarks of Rockwell Automation.

Trademarksnot belonging to Rockwell Automation are property of their
respective companies.

Copyright © 2002 Rockwell Automation. All rights reserved.
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1.1

1.2

Introduction

The Serial Converter module (MDCOMM-232)provides an
electronic communications interface between a computer and an
MD6O0ACdrive.It uses the full-duplex, RS-232 DF1 protocol.

The Serial Converter receives power from the connection to the

host product. An outside power sourceis not required.

This manualis intended for qualified electrical personnel.

Serial Converter Module Features

Features of the Serial Converter module include the following:

¢ Three status indicators (LEDs) report the operating status of the

module.

* DF1 serial baud rates of 9600 bps, 19.2 Kops, and 38.4 Kbps are
supported. 9600 bpsis the factory default.

¢ Anumberof configuration tools can be used to configure the

module, such as VSUtilities (V3.01 or higher) or terminal
emulation software.

Related Publications

Refer to the following related publications as necessary for more

information:

* 1770-6.5.16 - DF1 Protocol and Command Set Reference Manual

* D2-3488 - VS Utilities Getting Results Manual

These publications are available from:

http://www.theautomationbookstore.com
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1.3 Conventions Used in This Manual

The following conventions are used throughout this manual:

* Menu commandsare shownin bold typeface andfollow the

format Menu > Command. For example,if you read “Select File >
Open,” you should click the File menu and thenclick the Open
command.

¢ Parameters will be referenced by the parameter namefollowed by

the parameter numberasfollows: Reset Module (05).

 

1.4 Getting Assistance from Rockwell
Automation

If you have any questions or problems with the products described
in this instruction manual, contact your local Rockwell Automation
sales office. For technical assistance,call 1-800-726-8112.
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Getting Started

This chapter provides:

¢ Adescription of the Serial Converter module components

* A list of equipment supplied with the module

° A list of user-supplied equipmentrequired for installing and

configuring the module

* An installation checklist

2.1 Serial Converter Components
 

 

 

a Part Description
 

RJ45 Connection Standard RJ45 connector. The MDCBL-RJ45
cable (item 4) is plugged into this connector.
 

@ Status Indicators LEDsthat indicate module operation (data is
being received from the computer, data is being
sent to the computer). Refer to chapter 5,
Troubleshooting the Serial Converter, for more
information.
 

e RS-232 Serial Locking low-profile connector. The RECBL-SFC

 

   
Port serial cable (item 5) plugs into this connector.

o MDCBL-RJ45 RJ45 cable (2 m (6.6 ft)) with male-to-male RJ45
Cable connectors.

8 RECBL-SFC Serial cable (2 m (6.6 ft)) with a locking low-profile
Serial Cable connectorto connect to the Serial Converter and a 9-pin sub-miniature female D-connectorto

connect to a computer.  
 

Figure 2.1 — Components of the Serial Converter
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2.2

2.3

Required Equipment

Equipment Shipped with the Serial Converter

Whenyou unpack the Serial Converter, verify that the package

includes:

OQ) OneSerial Converter

One RECBL-SFCserial cable

One MDCBL-RJ45 cable

One VSUtilities CD

Serial Converter Module User Manual, D2-3502o
o
o
d
o
d

User-Supplied Equipment

To configure the Serial Converter, you must use oneof the following:

* VS Utilities software (V3.01 or higher)

¢ Terminal emulation software such as HyperTerminal

° VT-100 compatible terminal

Installation Checklist

This section is designed to help experienced users start using the
Serial Converter. If you are unsure how to complete a step, referto

the referenced chapter.

 

 

 

Step Action Refer to

1 |Review the safety precautions for the Throughout
Serial Converter. this manual.

2 {Install the Serial Converter. Chapter3,
Connect an MDCBL-RJ45cable to the Serial | Installing the
Converter and the host. Then, connect a Serial
RECBL-SFCserial cable to the Serial Converter
Converter and a computer. Make sure that

powerhas been applied to the host product.
See figure 2.2 for an example of a serial

connection to a personal computer.
 

3 |Configure the Serial Converter Chapter4,
parameters. Configuring
Use oneof the following to configure the Serial
parametersin the Serial Converter: Converter
* VS Utilities (V3.01 or higher)
* Terminal emulation software

¢ VT-100 compatible terminal      
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RECBL-SFC
    

Serial Converter
Computer   

Figure 2.2 — Example of Serial Connection to a Personal Computer
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Installing the Serial
Converter

Chapter 3 provides instructionsfor installing and removing the

Serial Converter.

3.1. Identifying the Supplied Cables

The following cables, supplied with the Serial Converter, are all you
should need to connect the Serial Converter to a product and

 

 

 

 

 

computer.

# Description Part Number

@ |Cable to connect the Serial Converter MDCBL-RJ45
to a host product (for example, an
MD60 drive).

@ |Serial cable to connect the Serial RECBL-SFC
Converter to the computer.     

Figure 3.1 — Cables

Important: To provide proper termination of the serial cable

shield, the computer chassis should be properly
grounded.If it is not possible or practical to ground the
computer chassis, then a ground wire should be
connectedto the serial cable shield at the shell of the
9-pin sub-miniature D-connector.

Important: The RJ45 cable shield must be properly grounded to
provide EMC protection. On the MD60drive,that
meansthatpin 16 on the drive control terminal block
must be connected to the drive earth ground terminal.
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3.2 Installing the Serial Converter

Important: The Serial Converter module must not beinstalled in
an area where the ambient atmosphere contains

volatile or corrosive gas, vapors, or dust. If the module
is not going to be installed for a period of time, it must

be stored in area whereit will not be exposed to a
corrosive atmosphere.

Use the following procedureto install the Serial Converter.

Step 1. Connect the Serial Converter to the drive using the
MDCBL-RJ45cable. Seefigure 3.2.

 

 

   
Figure 3.2 — Connecting the MDCBL-RJ45 Cable to the Serial Converter

Step 2. Connect the Serial Converter to the computerserial port
using the RECBL-SFCcable. Seefigure 3.3.

 

 

   
Figure 3.3 — Connecting the RECBL-SFC Cable to the Serial Converter

Step 3. Verify that poweris applied to the host. The Serial Converter
receives powerfrom the host. Therefore, the host must be

powered before the Serial Converter will operate.

The diamond LEDonthe Serial Converter flashes green to indicate

that the Serial Converteris properly installed and receiving power.If
it is not green, refer to chapter 5, Troubleshooting.
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3.3. Removing the Serial Converter

 

ATTENTION: If the Serial Converteris transmitting control
I/O to the product(indicated by a steady green diamond LED

on the Serial Converter), the product may fault when you
removeorreset the Serial Converter. Determine how your
productwill respond before removing or resetting aconnected
Serial Converter. Failure to observe these precautions could

result bodily injury and/or damage to equipment.  
 

Usethe following procedure to disconnect the Serial Converter:

Step 1. Disconnect the MDCBL-RJ45 cable from the host product
and then from the Serial Converter. To disconnectit, press
on the cable latch, and then pullit out.

Step 2. Disconnect the RECBL-SFCserial cable from the Serial
Converter and then from the computer.
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4.1

4.2

Configuring the Serial
Converter

This chapter provides information about configuring the Serial
Converter.

Fora list of parameters, refer to Appendix B, Serial Converter
Parameters. Fordefinitions of terms in this chapter, refer to the

Glossary.

Configuration Tools

The Serial Converter stores parameters and other informationinits

own non-volatile storage (NVS). You must, therefore, access the

Serial Converter to view andedit its parameters. Table 4.1 lists tools
that you can use to accessthe Serial Converter and editits

parameters.

Table 4.1 — Configuration Tools
 

 

 

 

Tool Referto:

VS Utilities software (V3.01 or higher) section 4.2 in this manual

Terminal emulation software section 4.3 in this manual

VT100-compatible terminal documentation for the
terminal     

Important: The RS-485serial port on the MD60 AC drive does
not need to be configured prior to using the Serial

Converter.

Using VS Utilities

With VS Utilities software, you can edit parameters in both the

Serial Converter and the connected drive. On an MD60drive, you
can also edit parameters in any of the attached peripherals.

Important: The parameter Adapter Cfg (01) must be set to Auto

(default) for VS Utilities software to operate.
HyperTerminal can be used if Adapter Cfg (01) needs
to be changed. Refer to section 4.3, Using Terminal
Emulation Software.
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This section is designed to help users start using VS Utilities. If you
are unsure how to complete a step, refer to the online help (select

Help > Help Topics).

Use the following procedure to configure the Serial Converter using

VS Utilities software:

 

 
 

Step 1. Select Explore > Configure Communication. Select the
communications port and baud rate that you are using.

Select either checksum and accept the default time for the

time-out.

Step 2. Select Explore > Connect> Local. A node eventually
appears under Devices.

Step 3. In the left pane,click the + signs to expandthe tree. Click

the product or Serial Converter to display parametersin
the right pane. Double-click a parameterto editit.

SAUiery |_joy x]

File Edit Explore Actions Help

OS 2 $-86) 94) = oe
EI Devices s [PPE [ Name [ value [units |

=| Node 2: - MD60drive | Adapter Cig Master

+). 0 - MD60 3-Phase,230V, {HP “212 DF1 Addr Cfg 2

. ig peRaeog eos
- . Omir chon ‘aul

Custom Views ~ 215 Reset Module Ready

Compare Results ~ 216 Clear DE1 Counts Ready
Roa? DFI Packets Sent 564

R218 DFI Packets Revd 566,

R213 Undelivered Msgs 0

Ro21.10 ENGs Sent 0
ARo2 141 ENQs Received 0

ROoo21.12 NAKs Received 0

ROo21.13 NAK Bad Packet 0

R214 NA&K No Memory 0

Ro2115 Ouplicate Msgs o
RO 21.16 OFT Addr Actual

R217 OF1 Rate Actual 36.4k bps

Ro21.18 Adapter Type Master 
For Help, press F1

      
Figure 4.1 — VS Utilities Screen
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4.3 Using Terminal Emulation Software

This section provides detailed instructions on how to use terminal
emulation software to access the Serial Converter so that you can

view and edit Serial Converter parameters or view the Serial
Converter event queue.

A variety of terminal emulation programs can be usedto establish a

serial connection between a computerand the Serial Converter.
The following instructions describe howto establish the initial serial
connection to the Serial Converter using a computer running
HyperTerminal (terminal emulation software provided with most

Windows 95/98/NT 4.0/2000/XP operating systems).

Important: The following instructions use screen captures from
Windows 95 HyperTerminal. If you are using a

difference operating system, HyperTerminal screens
maydiffer.

To use HyperTerminal to access the Serial Converter:

Step 1. Verify that the Serial Converteris installed correctly. Refer
to chapter3, Installing the Serial Converter.

Step 2. For Windows95,click Start from the desktop, and then

select Programs > Accessories > HyperTerminalto
display the HyperTerminal dialog box (see figure 4.2).
Your dialog box maylookslightly different. Continue to
step 3.
 

So C:\PROGRA~14ACCESS~14HYPERT... Ee) Es

File Edit View Help

AT&T Mailht hypertrn.cll
CompuServe. ht ad gel=e

hticons.dl EMCI Mailht

 

     

 
1 object{s) selected '6.00KB 4
    

Figure 4.2 — HyperTerminal Dialog Box in List View

For WindowsNT,click Start from the desktop, and then

select Programs > Accessories > HyperTerminal to
display the Connection dialog box (seefigure 4.3). Then,
go to step 4.

Step 3. Double-click Hypertrm.exe.

The Connection Description dialog box appears in the
HyperTerminal workspace. Seefigure 4.3.
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Peteeee] |?

wy
isd  New Connection

Enter a name and choose an icon for the connection:

Name:

Jeonverter
 

leor:

 

  >|

Cancel |

      
Figure 4.3 — Connection Dialog Box

Step 4. In the Name window, type any name(for example,
converter), and then select anyicon in the Icon box.

Step 5. Click OKto display the Phone Numberdialog box.

Step 6. In the Connect Using window,select the communications
port that you intend to use (usually COM1 or COM2).

Step 7. Click OKto display the Properties dialog box.

Step 8. Select the settings shownin figure 4.4.

Important: If you have previously set the parameter DF1 Rate Cfg
(03) to 19.2K or 38.4K, select that value in the Bits per
second box.

 

Ptytd BE

Port Settings |

 

Bits per second: t—~—siY

Data bits:—”—i‘

Parity:None

Stop bits:fo

Flow control:|More

Advanced... | Restore Defaults

— 4 Cancel | Apple |

Figure 4.4 — COM1 Properties Dialog Box
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Step 9. Click OK. A blank HyperTerminal workspace appears.

Step 10. Select File > Properties to display the Properties dialog
box.

Step 11. Click the Settings tab. Seefigure 4.5.

 

converter Properties HE

Phone Number Settings

Function, arrow, and ctrl keps act as

© Terminal keys Windows keys

  
Ernulatior:

fvTio0 7] Terminal Setup... |

Backseroll buffer lines:

500

[- Beep three times when connecting or disconnecting

ASCIl Setup... |

Cancel |

Figure 4.5 — Converter Properties Dialog Box

   

 

    
Step 12. Under the area labeled Function, arrow, and ctrl keys act

as, select Terminal keys.

Step 13. In the Emulation box, select VT100.

Step 14. Click OK to display the HyperTerminal workspace.

TIP: Select File > Save to save the HyperTerminal configuration

that you just created. In future connections, you can select the

saved configuration and quickly connect to the Serial Converter.

Step 15. Press Enteruntil the main menu appears (see figure 4.6).

 

Main Menu - Enter Number for Selection

1> Display Setup Parameters

2> Display Event Queue

3> Flash Upgrade   
Figure 4.6 — Main Menu
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4.4

 

 

 

 

 

 

To do this: See section

Edit the serial port rate 4.4

Edit the fault action 45

View the event queue 5.3.1

View DF1 data 5.4

Update the firmware C-1    
If no text or meaningless text appears instead of the Main Menu,
adjust the baud rate in your software. Refer to section 5.5 for

detailed instructions.

Navigating in the Terminal Emulation Software

Table 4.2 describes the keys to used to navigate the terminal

emulation software.

Table 4.2 — Key Descriptions

 

Key Description
 

[0]: ; [?] In the main menu, keys 1 — 3 select a menu option.
In the parameter screen, keys O- 9 enter a value.
 

Display the main menuor abort changes to a
parameter.
 

OR Scroll through parameters or events.

 

[== Jor Scroll through the values for a parameter.

    Savea value for a parameter.

 

Setting the RS-232 Serial Port Rate
(DF1 Rate)

The serial port rate, sometimes called baud rate or DF1 rate, is the

speed at which the computer and Serial Converter communicate
over RS-232. You can select a serial port rate of 9600, 19.2K, or
38.4K with the Serial Converter. The factory default serial port rate

is 9600.

Important: If you changethe serial port rate in the Serial

Converter, you mustset your software to use the
sameserial port rate. The Serial Converter must be

reset or power cycled before baud rate changes take

effect.
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To set the serial port rate:

Step 1. Set DF1 Rate Cfg (03) to the desired rate. Figure 4.7
shows a sample HyperTerminal screen.

 

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

3> DF1 Rate Cfg = 9600   
Figure 4.7 — DF1 Rate Cfg Parameter (03) in HyperTerminal

Step 2. Reset the Serial Converter. Refer to section 4.6.

Step 3. Set the serial port rate in your software to match the new
serial port rate in the Serial Converter.

4.5 Setting the Fault Action
 

 

ATTENTION: The setting of Comm Fit Action (04)
determines the action of the Serial Converter and
connected productif DF1 serial communications are

disrupted. By default, this parameterfaults the
product. You can set this parameter so that the

product continuesto run. Ensure that the setting of
this parameter doesnot create a hazard. Failure to
observethis precaution could result bodily injury
and/or damage to equipment.   

By default, when DF1 serial communications are disrupted (for

example, a serial cable is disconnected) and control I/O is being

transmitted, the Serial Converter and connected product respond by

faulting. You can setthe actionslisted in table 4.3.

Table 4.3 — Selections for Product Response to Communication Fault

 

 

 

 

  

Action Description

Fault The productwill fault (Default).

Stop The productwill stop and notfault (drive products
only).

Zero data The productis sent 0 for output data after a
communications disruption. This does not command a
stop.

Hold last The product continuesin its present state after a
communications disruption.   
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4.6

To changethefault action, set the value of Comm Fit Action (04) to
the desired fault action. Figure 4.8 shows a sample HyperTerminal
screen.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

4> Comm Flt Action = Fault   
Figure 4.8 — Comm Fit Action Parameter (04) in HyperTerminal

Changesto this parametertake effect immediately. A reset is not
required.

Resetting the Serial Converter
 

ATTENTION: Ifthe Serial Converteris transmitting
control I/O to the product(indicated by a steady
green diamond LED onthe Serial Converter), the
product may fault when you removeor reset the
Serial Converter. Determine how your productwill
respond before removing or resetting a connected
Serial Converter. Failure to observe this precaution
could result bodily injury and/or damageto
equipment.   

After you change some parameters, you mustreset the Serial

Converterfor the new setting to take effect. You can resetit by
removing and then reapplying power or by using Reset Module (05).

To reset the Serial Converter, set Reset Module (05) to either Reset

Module or Set Defaults. Reset Module will reset the Serial
Converter. Set Defaults will set all parameters in the Serial
Converterto their factory-default values. Figure to figure 4.9 for a

sample HyperTerminal screen.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

5> Reset Module = Reset Module   
Figure 4.9 — Reset Module Parameter (05) in HyperTerminal

After you enter the Reset Module value, the Serial Converterwill be

reset. The value in Reset Module (05) will then return to Ready.

 

4-8 Serial Converter Module (MDCOMM-232)



 

Troubleshooting

the Serial Converter

Chapter 5 provides information to troubleshoot the Serial Converter.

5.1 Understanding the Status Indicators
(LEDs)
The Serial Converter reports its status using status indicators. See

figure 5.1.

 

 

 

 

 

     

Status
# Indicator Description Refer to Section

@ |Diamond —|Serial Converter 5.1.1
status

@ RX Serial Converteris 5.1.2
receiving data

@ TX Serial Converteris 5.1.3

transmitting data   
Figure 5.1 — Status Indicators on the Serial Converter

Sections 5.1.1 through 5.1.3 describe whatthe state of each
indicator means.Notethatif all status indicators are off, the Serial

Converteris not receiving power. Refer to chapter 3 for installation
instructions.

 

Troubleshooting the Serial Converter 5-4



5.1.1 Diamond Status Indicator
 

ATTENTION: If the Serial Converteris transmitting control
I/O to the product(indicated by asteady green diamond LED

on the Serial Converter), the product may fault when you
remove or reset the Serial Converter. Determine how your
productwill respond before removing orresetting a Serial
Converter. Failure to observe this precaution could result

bodily injury and/or damage to equipment.
 

Table 5.1 — Diamond Status Indicator: State Definitions
 

 

 

 

 

 

     
 

State Cause Corrective Action

Off Serial Converter is not e Securely connect cables.

poweredoris in Flash
programming mode. * Apply powerto the product.

¢ Wait while Flash is in progress.

Flashing Serial Converteris Noaction required.

Green operating and not Removing or resetting the Serial
transmitting control /O. Converter will not cause a serialfault

in the product.

Steady Serial Converteris No action required.

Green operating andis or was Removing or resetting the Serial
transmitting control /O. Converter may causea serialfault in

the product.

Flashing The product has not e Securely connect cables.

Red acknowledged the . .
Serial Converter. Make sure Adapter Cfg (01) is set to

Auto.

steady Linkfailure. * Securely connectcables.
e

° Replace the cable.

* Cycle powerto the product.

Orange Contact Rockwell Automation

Technical Support.
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5.1.2 RX Status Indicator

Table 5.2 — RX Status Indicator: State Definitions
 

 

   the computer.  

State Cause Corrective Action

Off Serial Converter is_|* Verify that the drive is configured to use
notreceiving data. the RS-485 port.

* Securely connectcables.

* Apply powerto the product.

* Configure the computer software to use

the sameserial port rate as the Serial
Converter

Flashing Serial Converter is No action required.
Green receiving data from

 

5.1.3. TX Status Indicator

Table 5.3 — TX Status Indicator: State Definitions
 

 

 

  the computer.  

State Cause Corrective Action

Off Serial Converter is |* Verify that data is being transmitted.
not transmitting
data. * Securely connect cables.

° Apply powerto the product.

Flashing Serial Converter is No action required.
Green transmitting data to
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5.2 Module Diagnostic Items

Table 5.4 list module diagnostic items that can be accessed using

 

 

 

 

 

 

VS Utilities.

Table 5.4 — Module Diagnostic Items

No. Name Description

1 |Field Flash |Numberoffield flashes recorded.

Cnt

2 |Adapter The numberof events in the event queue.
Events

3 |Reference |Host’s Reference Command.

4 /Common Host’s Common Logic Command.
Logic Cmd

5 |Common Host’s CommonLogic Status.
Logic Sts     6 |Feedback Host’s Feedback Status.
 

5.3 Viewing and Clearing the Event

Queue

The module maintains an event queue that reports the history of its
actions. You can view the event queue using VS Utilities or terminal
emulation software (such as HyperTerminal).

Manyevents in the event queue occur under normaloperation. If

you encounter unexpected communications problems, the events
may help you or Reliance Electric personnel troubleshoot the
problem. Table 5.5 lists events that may appearin the event queue.

Table 5.5 — Event Descriptions
 

 

 

 

 

 

 

 

 

 

 

 

Event Description

No Event FO — No Event Present

Adapter Reset F1 — Adapter Entered Reset Condition

Slave Detected F2 — Slave was Detected to be Present by Master

Slave Removed F3 — Slave was Detected to be Removed by Master

Host Timeout F4 — Timeout Condition on Msg to Host

Slave Timeout F5 — Timeout Condition on Msgto Slave

Master Timeout F6 — Timeout Condition on Msg to Master

Serial Timeout F7 — Timeout on Serial 232 side (w/Control Enabled)

Control Enabled F8 — Control Enabled to Host

Control Disabled |/F9— Control Disabled to Host

EEPROM Sum Fit |F10 — Checksum on EEPROMIssue    
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5.3.1

5.3.2

5.4

Viewing the Event Queue

To view the event queue:

Step 1. Access the event queue using a configuration tool. Refer

to section 4.1.

Step 2. Scroll through events in the event queue. The most recent
event can be found at 2R > Event Queue 1. The R stands
for Read Only. Figure 5.2 shows an example of the event
queuein HyperTerminal.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

  2R> Event Queue 1 = Normal Startup
 

Figure 5.2 — Example of Event Queue in HyperTerminal

Clearing the Event Queue

To clear the event queue:

Step 1. Access the event queue using a configuration tool. Refer

to section 4.1.

Step 2. Set the value of 1 > Clr Event Queue to Enable, and then
press Enterto clear the event queue.Figure 5.3illustrates
clearing the event queue in HyperTerminal.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

1> Clr Event Queue = Enable   
Figure 5.3 — Clearing the Event Queue in HyperTerminal

Viewing and Clearing DF1 (Serial
Port) Communication Statistics

If you encounter unexpected communications problems or are

creating an application that uses DF1 data, you can view the
communicationsstatistics in the Serial Converter. Parameters 06
through 17 store this data.

To view and clear DF1 data, you must access the main menuin the
Serial Converter firmware. Refer to section 4.1.
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5.4.1 Viewing DF1 Data

To view DF1 data:

Step 1. Access the parametersin the Serial Converter using a
configuration tool. Refer to section 4.1.

Step 2. Scroll through the DF1 parameters. Parameters 06
through 17 contain DF1 data. For a description of each

parameter, refer to Appendix B, Serial Converter

Parameters. Figure 5.4 shows DF1 data viewed in
HyperTerminal.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

7R> DF1 Packets Sent = 0  
 

Figure 5.4 — Viewing DF1 Data in HyperTerminal

5.4.2 Clearing DF1 Counters

To clear DF1 counters:

Step 1. Access the parametersin the Serial Converter using a
configuration tool. Refer to section 4.1.

Step 2. Set the value of Clear DF1 Counts (06) to Clear Counts,
and then press Enterto clear the DF1 data. Figure 5.5
shows DF1 counters cleared in HyperTerminal.

 

Press the UP ARROW or DOWN ARROW key to scroll

through the parameter list. Press the LEFT ARROW or

RIGHT ARROW key to modify parameter values. Press

the ENTER key to save a new value.

6> Clear DF1l Counts = Clear Counts  
 

Figure 5.5 — Clearing DF1 Counters in HyperTerminal
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5.5 Troubleshooting Problems

Table 5.6 — Troubleshooting the Serial Converter
 

Problem Corrective Action
 

You are unable to
establish a connection

between your computer
and the Serial
Converter.

° |f the status indicators are off, connect the

cables and apply powerto the product.

* Configure your software and Serial Converter
to use the same COMMport andserial port
rate (baud rate).
 

After changing the serial

port rate, you are no
longer able to
communicate with the

Serial Converter and
connected product.

For example, in
HyperTerminal,
meaningless text

appears on the screen
when you press Enter.
In VS Utilities,
parameter values are
not updated.

Resetthe serial port rate in the software.
Instructions are included here for resetting the
serial port rate in HyperTerminal and VS Utilities.

If you are using a different configuration tool,
refer to its user manual.

HyperTerminal

1. Select File > Properties, and then click
Configure.

2. Select the new baud rate, and then click OK.

3. Save and close HyperTerminal.

4. Double-click on your HyperTerminalfile (*.ht)

to restart HyperTerminal.

5. Press Enter until the main menu appears.

VS Utilities

1. Select Explore > Configure
Communication.

2. Select the new baud rate. VS Utilities should

start updating values again.If it does not,
restart VS Utilities.
 

You set a new serial port

rate, but the Serial
Converter isstill using
the old serial port rate.

Reset the module. Refer to chapter 4.

 

No communications to
drive.  * Verify cable connections.

¢ Make sure Adapter Cfg (01) is set to Auto.
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Technical Specifications

Communications

RS-232 Side
Protocol RS-232 Serial DF1, Full Duplex
Port Rate 9600, 19.2K, or 38.4K

Data Bits 8

Parity None
Stop Bits 1
Flow Control None

Error CRC or BCC (Auto-Detected)

Host Side
Data Rates 19.2K

Electrical

Consumption 170 mA at +5V DC
The Serial Converter draws the required
powerfrom the connected product. An
external power sourceis not required.

Mechanical

Dimensions 103.5 x 73.4 x 23.6 mm (4.08 x 2.89 x 0.93 in)

Weight 70.88 g (2.5 oz)

Regulatory Compliance

UL 508C and CUL
CE EN-61800-3

CTick AS/NZs 2064, Group 1, Class A

Important: Forthis product to be CE- and CTick-compliant, the
shield of the serial cable and RJ45 cable must be

terminated as described in section 2.1.
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Environmental

Temperature

Operating
Storage

Relative Humidity

Atmosphere

Vibration
Operating
Non-Operating

Shock
Operating

Non-Operating

0° to +50°C (32° to 122°F)
-40° to +85°C (-40° to 185°F)

5 to 95% non-condensing

Important: Module mustnotbeinstalled in
an area where the ambient atmosphere

contains volatile or corrosive gas, vapors,

or dust. If the module is not going to be
installed for a period of time, it must be
stored in an area whereit will not be

exposedto a corrosive atmosphere.

2.5 G @5 Hz-2 KHz
5 G @5 Hz-2 KHz

30 G peak acceleration, 11(+/-1)ms pulse
width

50 G peak acceleration, 11(+/-1)ms pulse
width
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Serial Converter Parameters

 

01 Adapter Cfg

Range: 0 = Auto
1 = Master
2 = Slave

Default: 0 = Auto

Type: Read/Write

Reset Required: Yes

Selects the module’s modeof operation.

Important: Adapter Cfg (01) must be set to Auto (default) for
VS Utilities to operate. HyperTerminal can be usedif
Adapter Cfg (01) needs to be changed.

 

02 DF1 Addr Cfg

Range: 0 to 254

Default: 1

Type: Read/Write

Reset Required: Yes

Selects the DF1 node address for the Serial Converter. This is a

decimal value.

 

03 DF1 Rate Cfg
Range: 0 = 9600

1=19.2K
2 = 38.4K

Default: 0 = 9600

Type: Read/Write

Reset Required: Yes

Selects the serial port rate for the RS-232 DF1 serial port on the
Serial Converter.

Important: If you changethe serial port rate in the Serial
Converter, you must set your software to use the
sameserial port rate. The Serial Converter must be
reset or power cycled before baud rate changes take
effect.
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04 Comm Fit Action

Range: O = Fault
1 = Stop
2 = Zero Data
3 = Hold Last

Default: 0 = Fault

Type: Read/Write

Reset Required: No

Selects the action that the Serial Converter and producttakeif the
Serial Converter detects that DF1 serial communications are

disrupted. This setting is effective only if control I/O is transmitted
through the Serial Converter.

ATTENTION: Comm Fit Action (04) lets you
determinethe action of the Serial Converter and
connected productif communications are disrupted.
By default, this parameterfaults the product. You can
set this parameter so that the product continues to
run. Precautions should be taken to ensurethat the
setting of this parameter does not create a hazard
of injury or equipment damage.Failure to observe
this precaution could result in bodily injury and/or
damage to equipment.

05 Reset Module

Range: 0 = Ready(No action)
1 = Reset Module (Resets the Serial Converter)
2 = Set Defaults (Restores the Serial Converter

to its factory-default settings.)

Default: 0

Type: Read/Write

Reset Required: No

This parameter is acommand.The value will be set to Ready after a
Reset Module commandor Set Defaults command has been
performed.

ATTENTION: If the Serial Converteris transmitting
control I/O to the product(indicated by a steady
green diamond LED onthe Serial Converter), the
product may fault when you remove or reset the
Serial Converter. Determine how your productwill
respond before removing or resetting a connected
Serial Converter. Failure to observe this precaution
could result in bodily injury and/or damage to
equipment.
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06 Clear DF1 Counts

Range: 0 = Ready(No action)
1 = Clear Counts

Default: 0 = Ready(No action)

Type: Read/Write

Reset Required No

Resets the DF1statistical parameters (numbers 07 to15) to 0 if set
to Clear Counts. This parameter is a command. The value will be
set to Ready after a Clear Counts command has been performed.

 

07 DF1 Packets Sent

Range: 0 to 4294967295

Default: 0

Type: Read Only

Number of DF1 packets sent by the Serial Converter. The value of
this parameter is normally approximately equal to the value of

DF 1 Packets Revd (08).

 

08 DF1 Packets Revd

Range: 0 to 4294967295

Default: 0

Type: Read Only

Numberof DF1 packets received by the Serial Converter. The value
of this parameteris normally approximately equal to the value of

DF1 Packets Sent(07).

 

09 Undelivered Msgs

Range: 0 to 65535

Default: 0

Type: Read Only

Number of DF1 messagesthat were sent but not acknowledged.

This value is normally a low value.If it is continually incrementing

and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.
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10 ENQs Sent

Range: 0 to 65535

Default: 0

Type: Read Only

Number of ENQ (Enquiry) characters sent by the Serial Converter.

This value is normally a low value.If it is continually incrementing
and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.

11. ENQs Received

Range: 0 to 65535

Default: 0

Type: Read Only

Number of ENQ (Enquiry) characters received by the Serial
Converter.

This value is normally a low value.If it is continually incrementing
and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.

12  NAKs Received

Range: 0 to 65535

Default: 0

Type: Read Only

Numberof NAK (Negative Acknowledgement) characters received
by the Serial Converter.

This value is normally a low value.If it is continually incrementing
and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.

13 NAK Bad Packet
Range: 0 to 65535

Default: 0

Type: Read Only

Number of NAKs (Negative Acknowledgements) sentby the Serial
Converter because of corrupt packets (improper protocol
messages) as determined by the Serial Converter.

This value is normally a low value.If it is continually incrementing
and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.
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14 NAK No Memory

Range: 0 to 65535

Default: 0

Type: Read Only

Number of NAKs (Negative Acknowledgements) sentby the Serial

Converter becauseit did not have sufficient memory to buffer the
incoming messages. The Serial Converter runs out of memoryif a
commandwasnot completed and there is no place to save the new
commands.

This value is normally a low value.If it is continually incrementing
and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.

 

15 Duplicate Msgs

Range: 0 to 65535

Default: 0

Type: Read Only

Numberof duplicate messages sent by the Serial Converter. This

value contains the total number of consecutive messages received

by this device with the same TNS(Transaction Sequence) number.

This value is normally a low value.If it is continually incrementing

and you are having communications problems, use a lower baud
rate or replace the RECBL-SFCserial cable.

 

16 DF1 Addr Actual

Range: 0 to 254

Default: 0

Type: Read Only

DF1 addressactually used by the Serial Converter.

 

17 DF1 Rate Actual

Range: 0 = 9600
1-19.2K
2=38.4K

Default: 0 = 9600

Type: Read Only

Serial port rate actually used for the DF1 serial port on the Serial

Converter.
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18 Adapter Type

Range: O = Master
1 = Slave

Default: 0 = Master

Type: Read Only

The module’s present modeof operation.
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Flash Updates

Appendix C provides information on updating peripheral product

firmware.

C.1 Preparing for a Flash Update

Please take the following precautions to ensure a successful Flash
update:

Obtain the new firmware version from Rockwell Automation. Save

it to the hard drive of the computer. Do not attempt to perform a
Flash procedure from a floppy disk or a network.

Readall instructions supplied with the new firmwarefile.

Use a computer running terminal emulation software that
supports Xmodemtransfers (for example, HyperTerminal).

Record parametervaluesin the device that will be Flashed.

Updates may reset parametersto their default settings.

Ensure that the host product (MD60 ACdrive) is stopped.

Closeall programs except the terminal emulation program that
you are using to Flash the Serial Converter.

Disable the screen saver and antivirus programsso that they do

not start during the Flash process.

If you are using a laptop computer, turn off the FIFO buffers in

HyperTerminal. In HyperTerminal, select File > Properties to
display the Properties dialog box. Click Configure, and then click

Advanced. Ensure that a check mark does not appear nextto
Use FIFObuffers.
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C.2 Performing a Flash Update with
HyperTerminal
 

ATTENTION:Whenyou perform a Flash update,the
productwill faultif it is receiving control I/O from the

Serial Converter. Verify that the product has stopped
safely before beginning a Flash update.Failure to
observethis precaution could result bodily injury
and/or damage to equipment.

ATTENTION: If you interrupt a Flash procedurethat

is updating boot code, the device may become
inoperable. To prevent this damage,follow the
instructions provided with the new firmwarefile and
do not interrupt a Flash procedure while boot code
is being Flashed. Failure to observe this precaution

could result in damageto, or destruction of,
equipment.    

Step 1. In the main menu, press 3 to Update Flash program. The
screen in figure C.1 will immediately appear.

 

To update the Flash memory, you need a terminal

program capable of downloading a binary file using

the XMODEM protocol and a Flash update file from

Rockwell Automation. When you press 'Y' to signal

that you are ready to proceed, the terminal program

will start displaying the letter 'C'. This signals

the XMODEM protocol that the download may proceed.

You then have one minute to start the transfer.

Press CTRL-X to cancel an update started by

mistake. Are you ready to proceed? (Y/N)    
Figure C.1 — Flash Menu

Step 2. If the Flash can be completed safely, type Y. Theletter “C”
repeatedly appears.It is the Xmodem prompt and continues
to appear until you send a binaryfile.

Important: Press Ctrl + X to cancel a Flash update procedure.

Step 3. Select Transfer > Send File to display the SendFile dialog
box. Seefigure C.2.

Step 4. Click Browse and navigate to the Flash file.

Step 5. Double-click the file. Its name appears in the Filename box.

Step 6. In the Protocol box, select Xmodem.
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Mester ete 7x

Folder: C:\Program Files\4ccessones‘\Hyperl erminal

 

 

Filename:

Je:\temp', Flash File.bin Browse...

Protacal:

|modem |

 

      
Figure C.2 — Send File Dialog Box

Step 7. Click Send. A dialog box appears and reports the progress
of the download. Whenit is complete, the message

“Operation Complete” appears.

Important: Keep the device powered for 15 secondsafter the

operation has completed.

Step 8. Press Enter to return to the main menu.
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Problems
C.3 Troubleshooting Potential Flash

Table C.1 — Flash Troubleshooting
 

Problem Description Corrective Action
 

“Transfer Cancelled by
Remote System”
message appears and
the Flash is not

completed.

« Restart HyperTerminal and
repeat the Flash procedure.

* If you are using Windows NT 4.0,
install SP3 or later. Windows NT
service packs are available from

the Microsoft website:
http:/Awww.microsoft.com.

« Download a HyperTerminal

Private Edition update from the
Hilgraeve website:
http:/Avww.hilgraeve.com.

(Please note that there is a
license requirement with this
software.) Then, perform the
Flash procedure again.
 

The “Xmodem File Send”
for dialog box appears,
but the Flashfile is not

transferred.

* Verify that you have selected the
Xmodemprotocolin the Sendfile
dialog box.

* Verify that the newfile is on your
hard disk. Do not attemptto

Flash from a floppy disk or a
network.

* Verify that you are sending the
file within 60 secondsof pressing

Y to confirm that you want to

perform the Flash.
 

After completing a Flash,

you are unable to
communicate with the

Serial Converter. For
example, meaningless
text appears on the
HyperTerminal screen.  * Set the serial port rate to 9600.If

parameters are changed during a
Flash update,all parameters are
setto their default settings.
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application code - Codethat runs in the module after the boot

codecalls it. It performs the normal operations of the system.

block check character (BCC) - An error detection scheme where
the 2s complementof the 8-bit sum (modulo-256 arithmetic sum) of
all data bytes in a transmission block.It provides a meansof
checking the accuracy of each message transmission.

boot code- Codethat runs when the modulefirst receives power.It
checksbasic operations and then calls the application code.

cyclic redundancy check (CRC)- An error detection scheme
whereall of the characters in a message are treated as a string of
bits representing a binary number. This numberis divided by a
predetermined binary number(a polynomial) and the remainderis

appendedto the message as a CRC character. A similar operation
occurs at the receiving end to prove transmission integrity.

DF1 protocol - A peer-to-peerlink layer protocol that combines

features of ANSI X3.28-1976 specification subcategories D1 (data
transparency) and F1 (two-way simultaneous transmission with

embeddedresponses).

DF1 rate - A unit of signaling speed equal to the numberof discrete
conditions or signal events per second.It is also called baud rate or
serial port rate.

EEPROM- See non-volatile storage.

Flash update - The processof updating firmware in a device.

hold last - When communications are disrupted (for example, a

serial cable is disconnected), the converter and product can
respond by holding last state. Hold last state results in the product
receiving the last data received via the DF1 connection before the

disruption. If the product was in RUN modeand using the reference
from the converter, it will continue to run at the same reference.

non-volatile storage (NVS) - NVSis the permanent memoryof a
device. Devices such as the converter store parameters and other
information in NVS sothat they are not lost when the device loses

power. NVS is sometimes called EEPROM.

programmable controller communications command (PCCC)-
The protocol used by somecontrollers to communicate with devices
on a network. Some software products (for example, VS Utilities)

also use PCCC to communicate.
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serial converter- A device that provides an electronic
communications interface between an MD60 drive and a computer
with an RS-232 port. The MDCOMM-232Serial Converter uses a
full-duplex RS-232 DF1 protocol.

status indicators - LEDs that are used to report the status of a

device. There are three status indicators on the converter.

Type 0/Type 1/Type 2 Control - Whentransmitting I/O, the module
can usedifferent types of messagesfor control. The Type 0, Type 1,
and Type 2 events help Reliance Electric personnel identify the type
of messagesthat an moduleis using.

VS Utilities software - A Windows-basedsoftwaretoolfor
monitoring and configuring Reliance Electric products and modules.

Xmodem - Developed by Ward Christensen in 1978, Xmodem is a
protocol usedto transfer data. You can use the Xmodem protocolto
Flash the firmware in the Serial Converter or a device connected to
it.

zero data - When communicationsare disrupted (e.g., serial cable

is disconnected), the converter and product can respond with zero
data. Zero data results in the product receiving zero as values for
commanddata.If the product was in RUN modeandusing the
reference from the converter, it will stay in run mode but at zero
reference.
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Cc

cables, 3-1
communication specifications, A-1
configuration tools, 4-1

configuring the module, 4-1 to 4-8

D

DF1 data, viewing, 5-5

DF 1rate, setting, 4-6

dimensions, A-1

E

equipment required for installation, 2-2

event queue, 5-4

events
clearing, 5-4

viewing, 5-4

F

fault action, setting, 4-7

fault queue, see event queue

faults, see events

features, module, 1-1

firmware, updating, C-1
firmware, updating, see Flash

Flash update

instructions, C-1
troubleshooting, C-4

H

HyperTerminal

configuring module with, 4-3

updating firmware with, C-4

installation, 3-1 to 3-2
installation checklist, 2-2

L

LEDs, 5-1 to 5-3

manuals, related, 1-1

mechanical specifications, A-1

P

parameterdescriptions, B-1 to B-6

power consumption, A-1

publications, related, 1-1

R

regulatory compliance, A-1

removing the module, 3-3
resetting the module, 4-8

Rockwell Automation, contacting, 1-2
RS-232 serial port rate, setting, 4-6

S

serial connection example, 2-3
Serial Converter module

components, 2-1

configuring, 4-1 to 4-8

dimensions, A-1

features, 1-1

installing, 3-1 to 3-2

parameters, B-1 to B-6
removing, 3-3

resetting, 4-8

specifications, A-1

status indicators, 5-1 to 5-3
troubleshooting, 5-1 to 5-7

specifications, A-1

status indicators, 5-1 to 5-3

T

technical assistance, 1-2

troubleshooting, 5-1 to 5-7

Vv

VSUtilities, 1-1
configuring module with, 4-1
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